01/10/2025 10:53:00
Problem description
When the interface is called to determine whether the app is installed (IsAppInstalled), the returned result is inaccurate
Cause of the problem
iOS:
When the channel app is installed, the possible reasons for the above problem are as follows:
(1) The input parameters of the interface are incorrectly filled in
(2) The whitelist scheme identifier of the app is not configured or wrongly configured
(3) The actual identifier of the app changes, or a non-genuine app is installed
Warning: If the channel app is not installed in iOS, no scene with an inaccurate return result has been found yet when the interface is called to determine whether the app is installed.
Android:
When the channel app has been installed, the above problem may be caused by incorrectly filling in the input parameters of the interface.
When the channel app is not installed, the above problem may be caused by the fact that the system version available for the simulator is low.
Solution
iOS:
(1) Refer to Interface for judging whether App is installed to check or modify the interface's input parameters.
(2) Go to (Unity->.projmods) / (UE->DefaultEngine.ini->AdditionalPlistData) ->info.plist->LSApplicationQueriesSchemes to add / check the 'scheme' identifier of each channel. Among them, the 'scheme' identifier of each channel can be obtained from the corresponding channel documentation. For example, for WeChat channel related 'scheme' identifier, please refer to WeChat Channel Description to add / check it.
(3) The actual identifier of app changes in a certain version, or the installation of a non-genuine app causes the actual identifier of app to change. But the possibility that these situations occur is relatively low. Except WeChat and QQ channels, you can enter the input parameters for verification in the address box of the Webview when calling the IsAppInstalled interface. If the app can be initiated, this means that the current input parameter identifier is valid. The details are shown in the following figure.
Android:
If the channel app has been installed, please refer to Interface for judging whether App is installed to check or modify the interface's input parameters.
When the channel app is not installed, you can add a logic like "When WeChat login receives MSDK's returns retCode: 15 "Need Install APP", log in with QR code" to circumvent the problem. Or add a judgment logic like "Is the current device a real machine or an emulator" to circumvent the problem.
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